Engine fault warning - VW Eos Forum : Volkswagen Eos Forums

Go Back   VW Eos Forum : Volkswagen Eos Forums > Volkswagen Eos Forum > VW Eos Tech Q&A > Engine & Drivetrain

VWEosClub.com is the premier VW Eos Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Display Modes
Old 09-19-2019, 03:00 AM   #1
GatorEos
Junior Member
 
Join Date: Sep 2015
Location: FL
Posts: 8
Question Engine fault warning

I got this warning on my dash: Engine Fault Workshop! And the EPC light came on. This was a few days ago, stopped the car, restarted the car, no light no issues. Car seems to be running fine, then it flashed on again today.... Anyone seen this before?? Thanks in advance!

GatorEos

2009 Eos

Last edited by GatorEos; 09-19-2019 at 03:03 AM.
GatorEos is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-20-2019, 06:03 AM   #2
aku-aku
Senior Member
 
Join Date: Feb 2017
Location: PL
Posts: 599
Default

That behaviour means it is an intermittent condition. It could be one of many, many things and the first step is to connect VW-specific diagnostics, which will tell you exactly what's going on. Either take it to a mechanic that can deal with VW cars or invest in an OBDeleven dongle or VCDS.

If it happens three times in quick succession, you may find that the light stays on (but the car will still behave normally after a restart).
aku-aku is offline   Reply With Quote
Old 09-20-2019, 10:01 AM   #3
voxmagna
Senior Member
 
Join Date: Nov 2009
Location: Hampshire UK
Posts: 4,427
Default

Quote:
If it happens three times in quick succession, you may find that the light stays on (but the car will still behave normally after a restart)
When the light stays on there is a fault priority checking order. If the engine is considered to be at risk of damage you may only be able to drive it a few miles before it gets put into 'limp home' mode. E.g if there's a problem with the emissions control that could damage an expensive CAT or DPF it will do this after some miles. This type of problem can appear intermittent when these parts start to get blocked with soot or there are air leaks. 'Limp Home Mode' is a very speed restricted mode and you will know when you have arrived there!

You have the early warning, do as aku-aku suggests.
voxmagna is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-26-2019, 12:06 AM   #4
bossies1
Junior Member
 
Join Date: Mar 2011
Location: Northern California
Posts: 4
Default

We had a similar problem with our 2009, and it was caused by bad micro voltage connections for the fuel injection/throttle body. It eventually would go into limp mode. I used dielectric spray grease on the connectors and cleared the codes which worked for quite a while. Eventually we had the harness replaced which cost about $300 I think. Worked well. Those micro voltage connectors cause problems fast if there's any corrosion.
Just a thought.
bossies1 is offline   Reply With Quote
Old 09-26-2019, 04:43 AM   #5
GatorEos
Junior Member
 
Join Date: Sep 2015
Location: FL
Posts: 8
Default

Thank you all for the feedback. Couldn't get my VW tech to check it because his shop was so slammed. Had to replace a tire at Goodyear and they read the code as a throttle position sensor. Cleared the code and no problems.... for now.... Will get it to the VW man for a specific read. Thanks again!!
GatorEos is offline   Reply With Quote
Old 09-26-2019, 02:20 PM   #6
voxmagna
Senior Member
 
Join Date: Nov 2009
Location: Hampshire UK
Posts: 4,427
Default

Good luck because when I had a similar code and changed it, it wasn't exactly the TPS but the throttle body actuator on the other end (via a controller). It was gummed up and although I got a new part cheap, I was able to clean the old one to keep as a spare. Car diagnostics results often lack AI and are sometimes imperfect, which is why we still need trained technicians.
voxmagna is offline   Reply With Quote
Old 09-26-2019, 03:56 PM   #7
bossies1
Junior Member
 
Join Date: Mar 2011
Location: Northern California
Posts: 4
Default

TPS is the code we had. Check the connectors, being careful to not break the clips, spray with dielectric grease and reconnect. Clear the codes (I used an OBD2 scanner $20 or so on Amazon) and see if that helps.

I used a scanner like the "LAUNCH OBD2 Scanner CR319 Scan Tool".

Good luck!
bossies1 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Tags
engine fault workshop, epc, warning lights



Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT. The time now is 08:21 PM.



Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.