Volkswagen Eos Forum banner

turbo

  1. VW Eos Q&A
    Hi all, Firstly hoping you are all keeping well amidst the corona pandemic! I have encountered an issue with my VW Eos. I have plugged a fault code reader into the car, and received the following fault code -> 0065 (Turbo/Super Charger Underboost)...
  2. VW Eos Tech Q&A
    Hi all, hope y'all having a lovely day. this is my first post in the forum. Looking for some help/wisdom. My car is a 2008 Diesel TDi. After 2k rpm the engine loses a lot of power (that is because the turbo turns off as I can no longer hear it sucking in air). The engine malfunction light keeps...
  3. U.K.
    Hi,all, I have a 08 plate EOS 1.4 TSi The EM light has been on for a while but it has been running OK until recently when i lost power and the idle was lumpy and it kept stalling. Took it in for analysis and it seems that there was a problem with the boost sensors or something? Basically a...
  4. Airflow & Exhaust
    I have been looking all over the internet so I decided to stop here for some possible answers too. I have a 2007 VW EOS 4 cyl 2.0 (BPY) I just had my tensioner break and kill the engine head so that was replaced along with the timing belt, chain, and tensioner. this is my second day driving the...
  5. New User Introductions
    Hello all! My name is Ashley and I am the proud owner of a 2008 Eos Komfort 6-speed. Her name is BB (short for Black Beauty) and she's got a few mods. So far, the list of mods includes: Raceland Ultimo coilovers, BBS LM reps (STR LM 601's 17x7x5), axle back exhaust with chrome tips, custom cold...
  6. Airflow & Exhaust
    Hi guys, after a bit of help, just bought a 2.0t eos and need to pop a bit of 10k boost in to clean the engine. This is the first turbo car I've had and the instructions on the 10k boost advise spraying it directly into the turbo inlet. Thing is I have no idea where it is! Can anyone advise the...
  7. Engine & Drivetrain
    I just bought a 2008 Eos Turbo. It's the first turbo I've ever owned. The acceleration lags when first pressing on the gas. If I press on the gas pedal more, the car spins the front tires. It's hard finding the happy medium. Is that normal for turbo?
Top