Volkswagen Eos Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have a 2014 EOS and suddenly cannot put the top down due to the error that the Luggage Cover is not closed. It is closed! I've taken it in and out to make sure..giggled it....open and closed it...nothing same error! I'm thinking there is a sensor or something that needs to be cleaned and assuming somewhere near the luggage cover. Where? The last thing I want to do is spend time and $ in repair shop if it's something really simple I am missing. Anyone have an idea?
 

·
Super Moderator
Joined
·
2,343 Posts
Make sure the "omega" shaped clips on each side of the cover at the rear are in place, these have to click into place to align the cover magnet with the corresponding sensor to signal that the cover is is correctly closed so the roof opening can commence safely. The cover should make an audible "click" as both clips engage with the pins they clip onto to ensure the magnet is properly positioned to activate the sensor. This alignment is critical as the roof will not open if this sensor is not activated correctly.

In our case, the clips kept "springing out" when the cover was lifted and I ended up using a polyurethane adhesive to keep them in place. If ever required, the clips can be removed by "wire cutting" the adhesive joint.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Tightened the 'clips' that the rear pins rest in. The right side was loose. Still not working!

Where is the sensor/magnet? The whole cover has always been loose and can kind of move left to right by a fraction of an inch. It's dark or I'd upload a quick photo. Do you have a photo....we may not be talking about the same 'omega' shaped clips!
 

·
Registered
Joined
·
5,688 Posts
That switch unlike all the others is a simple microswitch. If you remove the left side pivot plastics for the cover and lift it out, the microswitch falls out. I can't remember exactly where it is but with my cover and trunk trim all removed it's flopping about on its wires in the tire well. I've wrapped tape around the operating button to keep it closed so I can fault find the roof.
 

·
Super Moderator
Joined
·
2,343 Posts
Tightened the 'clips' that the rear pins rest in. The right side was loose. Still not working!

Where is the sensor/magnet? The whole cover has always been loose and can kind of move left to right by a fraction of an inch. It's dark or I'd upload a quick photo. Do you have a photo....we may not be talking about the same 'omega' shaped clips!
Our MY09 Eos is sitting at home 400km from where we are now and we will not be back for at least 6 to 8 weeks so getting a photo is not possible. The MY09 luggage cover has two metal "omega" spring clip inserts [Omega is the shape of the greek letter O] in the bottom of the rear section [when looking from the rear of the car] of the luggage cover which clip onto the pins.

Your car is a MY14 and it appears VW have changed the design of the clip as a consequence of the problems experienced with the earlier design hence my comment does not apply.
 

·
Registered
Joined
·
5,688 Posts
The microswitch can spend a lot of time with its operating button pressed down which can weaken its spring. MY07 hasn't given any trouble yet but I know some have been heavy handed with the cover and break off a plastic pivot peg on one side. Then the switch won't work.
 

·
Member
Joined
·
497 Posts
This maybe totally unrelated but when I picked my car up after having a new interior fitted the roof would not operate and I got the luggage cover error but I knew it was correctly fitted. After resetting the auto windows I switched the ignition off and back on again and the error cleared and the roof worked as normal.
 

·
Registered
Joined
·
9 Posts
My 2008 has the switch on the LH side where the cover clips down. It is a simple mechanical switch that come come adrift from its location. Remove the spare wheel and undo the retaining screws to the boot lining in the spare wheel space and you can pull it up far enough to reach under and clip the switch back into its housing
 

·
Registered
Joined
·
5,688 Posts
I can hear mine 'click' when I slowly lower the cover.
 

·
Registered
Joined
·
6 Posts
Four years ago, I had the same problem with my 2013 Eos. It started one month after the 3-year warranty ended. When operating the top, sometimes the error would appear, other times not. Took it to the dealer who traced the problem to the trunk closing motor. That's the one sitting in the spare wheel well. They wanted $439 to replace it, including two hours labor. FYI, it's also called the "trunk lock latch actuator" or "actuator latch release".

I wrote down the part number stamped on the motor, then searched for "Eos Trunk Actuator Replacement Genuine OEM 1Q0827383B". There were many available - ebay, Amazon, car part dealers. I found a used one on ebay for $35. It came from a 2008 Audi. Looked brand new. Took me 45 minutes to replace it, saving me $400. Working perfectly ever since. Now they're about $50-100 on ebay.
 

·
Registered
Joined
·
5,688 Posts
Not wishing to create confusion, there are two types of error: One is 'Close luggage cover' which relates to the internal cover you lift up and down for roof op./not op and operates a microswitch near the bottom left corner. And the second error is given when the trunk LID isn't closed, because the pull down motor hasn't pulled the lid down tight on the seal. This motor sends the trunk lid closed confirmation to the system and usually puts out a warning ding, unlike the internal cover which just prevents the roof from opening.

I've assumed by 'Cover' the OP refers to the internal trimmed cover and not the trunk lid itself? The way to check this switch out is to short the switch wires together. If the roof error message goes away and the roof will start to open, you have a bad switch. If nothing happens and the error stays, you have a wiring problem. It's just simple logic!
 

·
Registered
Joined
·
6 Posts
I think you're right, Voxmagna. The error I received said "Close trunk lid", or words to that effect. I've also seen the luggage cover message when I forget to close it. Either will prevent the top from opening. My reply belongs in a different discussion. Thanks.
 
1 - 12 of 12 Posts
Top