Volkswagen Eos Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hi all - When I put the top down on my 2010 Eos the roof 'arms' do not align properly in order to clear the seats and go into the trunk. It is basically going down crooked. The car seems to think everything is normal, no error codes or anything. I noticed it as I was putting the roof down today and quickly released the lever. The top went back up normally. I tried it again hoping it was just a weird fluke but again the top started to fold down crooked and won't be able to clear the seats and rest properly. Is it possible it is low on hydraulic fluid? Has anyone else had this problem? Just dropped a good bit of $$$ replacing the water pump and engine cleaning so not looking forward to taking it to the shop!

Any input would be appreciated! :confused:
 

·
Registered
Joined
·
348 Posts
The "arms" are supposed to move "outward", away from each other (towards the outside of the car) before they stow themselves. Is that what they are not doing?
 

·
Registered
Joined
·
8,191 Posts
The EOS roof hydraulics uses rams which work in pairs. Therefore (unless something is bent) each side should retract the left and right hinges equally. I can only guess that one of the rams in a pair isn't responding to fluid pressure. If so you did the right thing by aborting the operation. That's why I don't have Smartop!

You can easily check the pump fluid level by just looking at the translucent reservoir. The system is supposed to be 'self bleeding' and bleeding is not required. The correct fluid level should stay there for life, unless there is a leak somewhere.
 

·
Registered
Joined
·
3 Posts
Hi all - When I put the top down on my 2010 Eos the roof 'arms' do not align properly in order to clear the seats and go into the trunk. It is basically going down crooked. The car seems to think everything is normal, no error codes or anything. I noticed it as I was putting the roof down today and quickly released the lever. The top went back up normally. I tried it again hoping it was just a weird fluke but again the top started to fold down crooked and won't be able to clear the seats and rest properly. Is it possible it is low on hydraulic fluid? Has anyone else had this problem? Just dropped a good bit of $$$ replacing the water pump and engine cleaning so not looking forward to taking it to the shop!

Any input would be appreciated! :confused:
Any luck on solving this issue
 
1 - 6 of 6 Posts
Top