Volkswagen Eos Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 · (Edited)
Does anyone know if someone makes an oil pump conversion kit for a 2012 EOS 2.0T?

I've been getting the low oil pressure light, to date I have changed the sensor and dropped the pan, cleaned the pickup tube and pan (nothing really there). I'm thinking the oil pump/balance shafts are the next things to check.
I know this kit exist for other VW and Audi engines.

Thanks,
Mark
 

·
Registered
Joined
·
6,716 Posts
AFIK the OE oil pump only has to make a lowly 40psi? Low oil pressure warnings tend to be about 10-15 psi.Either something is worn in the pump or its getting out somewhere? Why not try temporarily fitting a Tee and gauge to check the real pressure?
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
Thanks, this is true.
At idle, I can run the car forever and not have any lights. It seems to happen when I'm traveling at a higher rate of speed. I'm thinking the hex shaft may be stripped on the balance shaft. If that's the problem I'm wondering if there is an alternative.
 

·
Registered
Joined
·
6,716 Posts
OK got it. The hex drive shaft works at low speeds but is worn and loses grip at high speeds? Strange thing though that load on the pump and drive should be highest cold starting an engine with thicker oil when you would expect a drive shaft issue to show up? I think I saw one of those mod. kits. I can't remember the detail, but it looked like they had cut a hardened steel hex key to length with a disc cutter? If you were in the sump you shouldn't have been too far away to inspect the pump and drive to make sure.
 
1 - 4 of 4 Posts
Top