Volkswagen Eos Forum banner

21 - 25 of 25 Posts

·
Registered
Joined
·
2 Posts
I installed an RCD330 in my 2015. It was 100% 'plug & play'. Everything works perfectly (including all steering wheel controls). There was no coding, no adaptors, no additional wiring harnesses needed. I've had it in there now for about three months and love it. I mainly upgraded to it for the CarPlay, which is excellent. As it turns out, the 'Chinese brands' are actually factory VW units. For whatever reason, they do not advertise them as such, but they are indeed OEM Volkswagen equipment.
Sounds like what I need. Can you tell me specifically which one you got? There's a world of them out there. Amazon? Alibaba?
 

·
Registered
Joined
·
15 Posts
Then you’ll be good to go. I have the 10 channel Dynaudio and have determined that it is not compatible. I have a 187B NoName w/ rear USB mod. Looking to sell and reinstalling my RNS-510.

Let me know if you’re interested.
 

·
Registered
Joined
·
6,578 Posts
For whatever reason, they do not advertise them as such, but they are indeed OEM Volkswagen equipment.
That's not been my impression when I opened mine up and looked at the build quality and circuit boards? They may try to 'emulate' what the OE does but if you get one, try running V.W compatible diagnostics for the radio module 56?

If the Chinese clone radio is a perfect look alike copy, V.W diagnostics can scan and tone test each speaker sequentially, allowing you to check each channel is a separate channel with no 'fakery' and test the speaker for output. If it's connecting to Dynaudio speakers there should be 10 tone sqeaks in sequence from each speaker. The radio will also stay on when the ignition is off in the radio position whilst parked.
 
21 - 25 of 25 Posts
Top